#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<span class="num">\K\d(?:\.\d{2})?"
Local $sString = "<h1>" & @CRLF & _
" <span class="paper-name">some string</span>" & @CRLF & _
"</h1>" & @CRLF & _
"<div class="data-row">" & @CRLF & _
" <span class="num">0.25</span>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")