const regex = new RegExp('<span class="num">\\K\\d(?:\\.\\d{2})?', 'gm')
const str = `<h1>
<span class="paper-name">some string</span>
</h1>
<div class="data-row">
<span class="num">0.25</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}