import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\"num\">\\K\\d(?:\\.\\d{2})?";
final String string = "<h1>\n"
+ " <span class=\"paper-name\">some string</span>\n"
+ "</h1>\n"
+ "<div class=\"data-row\">\n"
+ " <span class=\"num\">0.25</span>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}