$re = '~<span class="num">\K\d(?:\.\d{2})?~m';
$str = '<h1>
<span class="paper-name">some string</span>
</h1>
<div class="data-row">
<span class="num">0.25</span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);