import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0+?(\\d{2})";
final String string = "001 - Filename 001.mp3\n"
+ "009 - Filename 009.mp3\n"
+ "010 - Filename 010.mp3\n"
+ "060 - Filename 060.mp3\n"
+ "086 - Filename 086.mp3\n"
+ "100 - Filename 100.mp3\n"
+ "1000 - Filename 1000.mp3\n"
+ "01001 - Filename 1001.mp3\n\n"
+ "01 - Filename with two leading numbers.mp3\n"
+ "1 - Filename with one leading number.mp3";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}