import re
regex = re.compile(r"^0+?(\d{2})", flags=re.MULTILINE)
test_str = ("001 - Filename 001.mp3\n"
"009 - Filename 009.mp3\n"
"010 - Filename 010.mp3\n"
"060 - Filename 060.mp3\n"
"086 - Filename 086.mp3\n"
"100 - Filename 100.mp3\n"
"1000 - Filename 1000.mp3\n"
"01001 - Filename 1001.mp3\n\n"
"01 - Filename with two leading numbers.mp3\n"
"1 - Filename with one leading number.mp3")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)