using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[IO](\d{3})?)(\w{12})";
string input = @"2:O5641057130214TESTBIC34XXX26264938281302141757N
2:I101YOURBANKXJKLU3003";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}