re = /(?<=[IO](\d{3})?)(\w{12})/m
str = '2:O5641057130214TESTBIC34XXX26264938281302141757N
2:I101YOURBANKXJKLU3003'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end