const regex = /(?<=[IO](\d{3})?)(\w{12})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[IO](\\d{3})?)(\\w{12})', 'gm')
const str = `2:O5641057130214TESTBIC34XXX26264938281302141757N
2:I101YOURBANKXJKLU3003`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}