$re = '/(?<=[IO](\d{3})?)(\w{12})/m';
$str = '2:O5641057130214TESTBIC34XXX26264938281302141757N
2:I101YOURBANKXJKLU3003';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);