import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([1-9]*)+)([\\+\\-\\*\\/]([1-9][0-9]*))+|([1-9][0-9]*)";
final String string = "a+5*4-1-3-4+0123456789-123456789/0+23a23+435/0123456+2\n"
+ "1/2+3asd3+4\n"
+ "1/0\n"
+ "0/0\n"
+ "0/1\n"
+ "a1a\n"
+ "12334\n"
+ "+2+\n"
+ "0987+2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}