use strict;
my $str = 'a+5*4-1-3-4+0123456789-123456789/0+23a23+435/0123456+2
1/2+3asd3+4
1/0
0/0
0/1
a1a
12334
+2+
0987+2';
my $regex = qr/(([1-9]*)+)([\+\-\*\/]([1-9][0-9]*))+|([1-9][0-9]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}