$re = '/(([1-9]*)+)([\+\-\*\/]([1-9][0-9]*))+|([1-9][0-9]*)/m';
$str = 'a+5*4-1-3-4+0123456789-123456789/0+23a23+435/0123456+2
1/2+3asd3+4
1/0
0/0
0/1
a1a
12334
+2+
0987+2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);