const regex = /(([1-9]*)+)([\+\-\*\/]([1-9][0-9]*))+|([1-9][0-9]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([1-9]*)+)([\\+\\-\\*\\\/]([1-9][0-9]*))+|([1-9][0-9]*)', 'gm')
const str = `a+5*4-1-3-4+0123456789-123456789/0+23a23+435/0123456+2
1/2+3asd3+4
1/0
0/0
0/1
a1a
12334
+2+
0987+2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}