package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?<fname>[^ (]+)(?:\((?<args>[^\)]+)\))?`)
var str = `func0 func-1(12) func-2(1, 2) func3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}