const regex = /\s*(?<fname>[^ (]+)(?:\((?<args>[^\)]+)\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?<fname>[^ (]+)(?:\\((?<args>[^\\)]+)\\))?', 'gm')
const str = `func0 func-1(12) func-2(1, 2) func3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}