// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(?<fname>[^ (]+)(?:\((?<args>[^\)]+)\))?").unwrap();
let string = "func0 func-1(12) func-2(1, 2) func3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}