import re
regex = re.compile(r"\s*(?<fname>[^ (]+)(?:\((?<args>[^\)]+)\))?", flags=re.MULTILINE)
test_str = "func0 func-1(12) func-2(1, 2) func3"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")