package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<pos>\d+)\.\s*([\w\s\,]+?)(\s+by\s[\w\s]+)(\(\d+\))$`)
var str = `2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
1. Edgar Allan Poe, The Raven, by Edgar Allan Poe (1525)
3. 1984 by George Orwell (1525)
4. 1984 by George Orwell (1525) No Ranking do Gutenberg
5. Beowulf: An Anglo-Saxon Epic Poem (658)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}