const regex = /^(?<pos>\d+)\.\s*([\w\s\,]+?)(\s+by\s[\w\s]+)(\(\d+\))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<pos>\\d+)\\.\\s*([\\w\\s\\,]+?)(\\s+by\\s[\\w\\s]+)(\\(\\d+\\))$', 'gm')
const str = `2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
1. Edgar Allan Poe, The Raven, by Edgar Allan Poe (1525)
3. 1984 by George Orwell (1525)
4. 1984 by George Orwell (1525) No Ranking do Gutenberg
5. Beowulf: An Anglo-Saxon Epic Poem (658)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}