$re = '/^(?<pos>\d+)\.\s*([\w\s\,]+?)(\s+by\s[\w\s]+)(\(\d+\))$/m';
$str = '2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
1. Edgar Allan Poe, The Raven, by Edgar Allan Poe (1525)
3. 1984 by George Orwell (1525)
4. 1984 by George Orwell (1525) No Ranking do Gutenberg
5. Beowulf: An Anglo-Saxon Epic Poem (658)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);