use strict;
my $str = '2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
2. PRide and Prejudice by Jane Austen (1302)
1. Edgar Allan Poe, The Raven, by Edgar Allan Poe (1525)
3. 1984 by George Orwell (1525)
4. 1984 by George Orwell (1525) No Ranking do Gutenberg
5. Beowulf: An Anglo-Saxon Epic Poem (658)';
my $regex = qr/^(?<pos>\d+)\.\s*([\w\s\,]+?)(\s+by\s[\w\s]+)(\(\d+\))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}