import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)(?:[^\\d\\s]*200B)?|P:\\h*)[^\\d\\s]*\\K(?!200B)\\d+";
final String string = "H: 290‐314 P: 280‐301+330U+200B+331string‐305+351+338‐308+310 [2]\n\n"
+ "Output: [280,301,330, 331, 305,351,338,308,310]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}