const regex = /https:\/\/.*\/(.*)\/(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/.*\\\/(.*)\\\/(.*)$', 'gm')
const str = `https://www.labnol.org/internet/duplicate-gmail-draft-emails/29124`;
const subst = `$1-$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);