re = /https:\/\/.*\/(.*)\/(.*)$/m
str = 'https://www.labnol.org/internet/duplicate-gmail-draft-emails/29124'
subst = '$1-$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result