import re
regex = re.compile(r"https:\/\/.*\/(.*)\/(.*)$", flags=re.MULTILINE)
test_str = "https://www.labnol.org/internet/duplicate-gmail-draft-emails/29124"
subst = "$1-$2"
result = regex.sub(subst, test_str)
if result:
print(result)