#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)\d{2}-\d{2}-(?:\d{4}|\d{2})(?!\d)"
Local $sString = "ggggg18-05-2018ggggg" & @CRLF & _
"ggggg18-05-2018ggggg12345678" & @CRLF & _
"ggggg18-05-18ggggg" & @CRLF & _
"ggggg18-05-18ggggg12345678" & @CRLF & _
"" & @CRLF & _
"ggggg2018-05-18ggggg" & @CRLF & _
"ggggg2018-05-18ggggg12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")