import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)\\d{2}-\\d{2}-(?:\\d{4}|\\d{2})(?!\\d)";
final String string = "ggggg18-05-2018ggggg\n"
+ "ggggg18-05-2018ggggg12345678\n"
+ "ggggg18-05-18ggggg\n"
+ "ggggg18-05-18ggggg12345678\n\n"
+ "ggggg2018-05-18ggggg\n"
+ "ggggg2018-05-18ggggg12345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}