using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)\d{2}-\d{2}-(?:\d{4}|\d{2})(?!\d)";
string input = @"ggggg18-05-2018ggggg
ggggg18-05-2018ggggg12345678
ggggg18-05-18ggggg
ggggg18-05-18ggggg12345678
ggggg2018-05-18ggggg
ggggg2018-05-18ggggg12345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}