const regex = new RegExp('(?<!\\d)\\d{2}-\\d{2}-(?:\\d{4}|\\d{2})(?!\\d)', 'gm')
const str = `ggggg18-05-2018ggggg
ggggg18-05-2018ggggg12345678
ggggg18-05-18ggggg
ggggg18-05-18ggggg12345678
ggggg2018-05-18ggggg
ggggg2018-05-18ggggg12345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}