import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=KUTY01\\s)-?\\d+\\.?\\d+";
final String string = "DELZZ 3301.23\n\n"
+ "KUTY 4.32 SERI -0.023\n\n"
+ "KUTY01 33.02\n\n"
+ "Fuzzy10 -0.923";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}