re = /(?<=KUTY01\s)-?\d+\.?\d+/m
str = 'DELZZ 3301.23
KUTY 4.32 SERI -0.023
KUTY01 33.02
Fuzzy10 -0.923'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end