const regex = /(?<=KUTY01\s)-?\d+\.?\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=KUTY01\\s)-?\\d+\\.?\\d+', 'gm')
const str = `DELZZ 3301.23
KUTY 4.32 SERI -0.023
KUTY01 33.02
Fuzzy10 -0.923`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}