import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*:)(?:[.#]\\w+|\\w+\\[.*\\])";
final String string = ".main {\n"
+ " property: value;\n"
+ "}\n\n"
+ "#header {\n\n"
+ "}\n\n"
+ ".one, .two a[href$=\".com\"] {\n"
+ " .subclass {\n"
+ " property: value;\n"
+ " }\n"
+ "}\n\n"
+ ".test:before, .test:after:active {}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}