$re = '/(?!.*:)(?:[.#]\w+|\w+\[.*\])/m';
$str = '.main {
property: value;
}
#header {
}
.one, .two a[href$=".com"] {
.subclass {
property: value;
}
}
.test:before, .test:after:active {}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);