re = /(?!.*:)(?:[.#]\w+|\w+\[.*\])/m
str = '.main {
property: value;
}
#header {
}
.one, .two a[href$=".com"] {
.subclass {
property: value;
}
}
.test:before, .test:after:active {}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end