import re
regex = re.compile(r"(?!.*:)(?:[.#]\w+|\w+\[.*\])", flags=re.MULTILINE)
test_str = (".main {\n"
" property: value;\n"
"}\n\n"
"#header {\n\n"
"}\n\n"
".one, .two a[href$=\".com\"] {\n"
" .subclass {\n"
" property: value;\n"
" }\n"
"}\n\n"
".test:before, .test:after:active {}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")