#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\w. ]+)(?<!\d)(\d+)\.(\w+)$"
Local $sString = "img123.png" & @CRLF & _
"(img) (123) (png)" & @CRLF & _
"img.123.png" & @CRLF & _
"(img.) (123) (png)" & @CRLF & _
"img_v01_1234.png" & @CRLF & _
"(img_v01_) (1234) (png)" & @CRLF & _
"img01_123.png" & @CRLF & _
"(img01_) (123) (png)" & @CRLF & _
"img.001.123.png" & @CRLF & _
"(img.001.) (123) (png)" & @CRLF & _
"img 001.12.png" & @CRLF & _
"(img 001.) (12) (png)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")