$re = '/^([\w. ]+)(?<!\d)(\d+)\.(\w+)$/m';
$str = 'img123.png
(img) (123) (png)
img.123.png
(img.) (123) (png)
img_v01_1234.png
(img_v01_) (1234) (png)
img01_123.png
(img01_) (123) (png)
img.001.123.png
(img.001.) (123) (png)
img 001.12.png
(img 001.) (12) (png)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);