use strict;
my $str = 'img123.png
(img) (123) (png)
img.123.png
(img.) (123) (png)
img_v01_1234.png
(img_v01_) (1234) (png)
img01_123.png
(img01_) (123) (png)
img.001.123.png
(img.001.) (123) (png)
img 001.12.png
(img 001.) (12) (png)';
my $regex = qr/^([\w. ]+)(?<!\d)(\d+)\.(\w+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}