import re
regex = re.compile(r"^([\w. ]+)(?<!\d)(\d+)\.(\w+)$", flags=re.MULTILINE)
test_str = ("img123.png\n"
"(img) (123) (png)\n"
"img.123.png\n"
"(img.) (123) (png)\n"
"img_v01_1234.png\n"
"(img_v01_) (1234) (png)\n"
"img01_123.png\n"
"(img01_) (123) (png)\n"
"img.001.123.png\n"
"(img.001.) (123) (png)\n"
"img 001.12.png\n"
"(img 001.) (12) (png)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")