#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([abc](?=[defghijkl]|$)|[def](?=[abcghijkl]|$)|[ghi](?=[abcdefjkl]|$)|[jkl](?=[abcdefghi]|$))+$"
Local $sString = "Sides: abc def ghi jkl" & @CRLF & _
"" & @CRLF & _
"These match:" & @CRLF & _
"ad" & @CRLF & _
"ga" & @CRLF & _
"adgjbehk" & @CRLF & _
"jgjgjad" & @CRLF & _
"" & @CRLF & _
"These have two letters from the same side next to each other:" & @CRLF & _
"add" & @CRLF & _
"ab" & @CRLF & _
"" & @CRLF & _
"Invalid letters:" & @CRLF & _
"adza" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")