$re = '/^([abc](?=[defghijkl]|$)|[def](?=[abcghijkl]|$)|[ghi](?=[abcdefjkl]|$)|[jkl](?=[abcdefghi]|$))+$/m';
$str = 'Sides: abc def ghi jkl
These match:
ad
ga
adgjbehk
jgjgjad
These have two letters from the same side next to each other:
add
ab
Invalid letters:
adza
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);