re = /^([abc](?=[defghijkl]|$)|[def](?=[abcghijkl]|$)|[ghi](?=[abcdefjkl]|$)|[jkl](?=[abcdefghi]|$))+$/m
str = 'Sides: abc def ghi jkl
These match:
ad
ga
adgjbehk
jgjgjad
These have two letters from the same side next to each other:
add
ab
Invalid letters:
adza
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end