import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([abc](?=[defghijkl]|$)|[def](?=[abcghijkl]|$)|[ghi](?=[abcdefjkl]|$)|[jkl](?=[abcdefghi]|$))+$";
final String string = "Sides: abc def ghi jkl\n\n"
+ "These match:\n"
+ "ad\n"
+ "ga\n"
+ "adgjbehk\n"
+ "jgjgjad\n\n"
+ "These have two letters from the same side next to each other:\n"
+ "add\n"
+ "ab\n\n"
+ "Invalid letters:\n"
+ "adza\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}