using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=<heading>.*?<\/heading>)";
string substitution = @"$0\n";
string input = @"<heading>فهرست اول</heading>hi my name is mahdi whats app <heading>فهرست دوم</heading>how are you";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}