const regex = /(?=<heading>.*?<\/heading>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=<heading>.*?<\\\/heading>)', 'g')
const str = `<heading>فهرست اول</heading>hi my name is mahdi whats app <heading>فهرست دوم</heading>how are you`;
const subst = `$0\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);