$re = '/(?=<heading>.*?<\/heading>)/';
$str = '<heading>فهرست اول</heading>hi my name is mahdi whats app <heading>فهرست دوم</heading>how are you';
$subst = "$0\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;