import re
regex = re.compile(r"(?=<heading>.*?<\/heading>)")
test_str = "<heading>فهرست اول</heading>hi my name is mahdi whats app <heading>فهرست دوم</heading>how are you"
subst = "$0\\n"
result = regex.sub(subst, test_str)
if result:
print(result)