package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d[0]*\d{3}([ .-])?\d{3}([ .-])?\d{4}|\d{3}([ .-])?\d{3}([ .-])?\d{4}|\(\d{3}\)([ ])?\d{3}([.-])?\d{4}|\(\d{3}\)([ ])?\d{3}([ ])?\d{4}|\(\d{3}\)([.-])?\d{3}([.-])?\d{4}|\d{3}([ ])?\d{3}([ .-])?\d{4}`)
var str = `(123).234.4567
(123)-234-4567
(617) 495-1797
(617) 495 1797
(617) 4951797
6174951797
617 4951797
jnnjn 0536 856 9766 jjjkkk
123.234.4567
123-456-4567
123.123-1234
123.123-1234
123 123-1234
123 123 1234`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}